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Unit 3: ActiveBPEL DesignerUnit 3: ActiveBPEL Designer

BPEL Fundamentals, Part 1

This is Unit #3 of the BPEL Fundamentals I course.  In this Unit we will look at 
ActiveBPEL Designer, the premier BPEL development tool.
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Unit ObjectivesUnit Objectives

At the conclusion of this unit, you will be familiar 
with:
– ActiveBPEL Designer Environment
– Working with projects and resources
– Web References

This session we will cover the ActiveBPEL Designer working environment, the 
structure of projects and resources and the use of Web References.
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ActiveBPEL DesignerActiveBPEL Designer

Visual design environment for creating, testing, 
deploying and debugging BPEL processes
– Designed around the BPEL specifications
– Based on the open-source Eclipse platform

Takes full advantage of the Eclipse Workbench features to 
enable BPEL building capabilities

ActiveBPEL Designer is a visual development environment that was designed to 
create BPEL processes.  It is based on the Eclipse platform, designed to implement 
the BPEL specifications and makes use of Eclipse Workbench features.  If you are 
an experienced Eclipse user, you may notice, however, that not all Eclipse 
functionality is implemented in ABD.  And, while in the background it is implemented 
as a plug-in, it is not currently available to configure it as such, that is, as a group of 
Eclipse plug-ins.  (This option may be available in future releases.)  You should 
therefore use the installer to load the program onto your machine.  ActiveBPEL 
Designer is free and functional, includes the ActiveBPEL Engine, which is open 
source, and it runs on a Tomcat server, which is provided.  It is currently only 
available on the Windows platform…
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ActiveBPEL Designer Welcome ScreenActiveBPEL Designer Welcome Screen

Overview
Find out what ActiveBPEL 
Designer is all about

Samples
Explore BPEL 
development samples

Tutorials
Let us guide you through 
ActiveBPEL Designer 
end-to-end tutorials

What's New
Find out what is new in 
this release

Note: You can return to this screen by selecting Note: You can return to this screen by selecting WelcomeWelcome from the from the HelpHelp menumenu

This slide is self-explanatory.  It shows the welcome screen with the buttons you 
use to find different kinds of information.  They are:
The Overview, which describes the tool and how it is used in a development 
context.
A Tutorial (which we highly recommend you do before taking any of our classes) 
that will help you familiarize yourself with the Designer.
An extensive directory of Sample code, including both introductory and advanced 
topics.
A "what’s new" in the tool for the most current release.  We are currently on version 
5.0, with a 5.x version due in the Summer of '08. 
Close the Welcome screen to enter ABD, and you can return to the Welcome 
screen at any time by using the Help->Welcome menu. 
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ActiveBPEL Designer FeaturesActiveBPEL Designer Features

Web References
– Global registry of SOA artifacts referenced by one or more 

processes

Process Editor
– Graphical layout of BPEL processes

Simulation
– Simulate process execution based on sample data prior to 

deployment

Process Deployment
– Wizard-based mechanism to deploy a process to an ActiveBPEL 

server

Debugging
– Remotely debug a process already deployed and running on an 

ActiveBPEL server

Help System
– HTML Based, searchable, context sensitive

To give you an overview of the product, here are some helpful features that come 
with ActiveBPEL Designer: 
Web References = a global registry of SOA artifacts - i.e., WSDLs and Schemas -
which can be viewed through various filters that give insight into the contents of 
those file types.
Process Editor = A graphical layout of your BPEL processes with full simulation 
capabilities.  This editor features drag & drop process construction and an extensive 
collection of wizards.
Simulation = Lets the User configure sample data to step through and verify all of 
the execution paths of your process in the Designer, prior to deployment.
Process Deployment = Uses a wizard to create a deployment package, greatly 
simplifying the procedure you go through to deploy your BPEL process onto an 
ActiveBPEL Server.
Debugging = Enables the User to perform remote debugging of a BPEL process 
that has already been deployed onto the server.
Help System = Provides Help in creating and deploying web services… and is a 
context-sensitive, searchable and html-based system.
We also have an ActiveBPEL Designer User Guide available that is installed with 
the product.  Check for the install location and then look for the “docs” folder to find 
the Guide.  Also, please note that deployment is vendor-specific, as far as the file 
types generated and the actual mechanics.   Process deployment is not part of the 
BPEL 2.0 specification.
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ActiveBPEL Designer Key Terms and ConceptsActiveBPEL Designer Key Terms and Concepts

Perspectives

Workbench

Resources
• Projects 
• Files
• Folders Editors

Views

This is what you see after you close the application's Welcome screen. 
The ActiveBPEL Designer Workbench is the whole thing, i.e., the entire working 
area of the application.  
The Designer's Perspectives are an Eclipse term that defines a pre-configured 
layout used by the workbench in order to accomplish a specific task.  There are 
several perspectives that come with the tool and you can also define your own.  
The Editors include the Process Editor, where you lay out the process itself… and 
other Editors for specific functionality.  These editors show as tabs across the 
bottom of the main canvas. 
Designer's Views give deeper insight into certain types and arrangements of 
process data… such as Process Variables view and the Activity Properties view.
Finally, Resources are the projects, files, folders, etc… that are in the current 
workspace.
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WorkbenchWorkbench

Refers to the desktop development environment
– Where you create, edit, test, deploy, debug BPEL 

processes

Each Workbench window contains one or more 
perspectives

Workbench is the central and defining element of the UI.  It is the main window of 
the application and all that it includes.
The Workbench is seen through a Perspective.  There are an unlimited number of 
Perspectives, each one looking at the same process data, but in different ways and 
for different purposes.
An example of this would be looking at your Process from the ActiveBPEL Design 
perspective and then looking at the same process from the ActiveBPEL Debug 
perspective.  You would see the same process, but with different layouts and with a 
different set of Views. 
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PerspectivesPerspectives

Defines the initial set and layout of views in the 
Workbench window
– In addition, usually defines an editor area

Provides a set of functionality aimed at 
accomplishing
– A specific type of task
– Working with specific types of resources
– Control over what appears in certain menus and 

toolbars

Can be tailored to make your own custom 
perspective

A Workbench window can have several separate Perspectives, only one of which is 
visible at any given moment.  Each Perspective has its own Views and Editors that 
are arranged for presentation on the screen, and these Perspectives are completely 
user-definable and saveable. 
They are usually created to:
accomplish a specific task…
work with specific resources…
define what appears in menus and toolbars
If you open up ActiveBPEL Designer and click on the icon next to the Perspectives 
you will see a lists of the available choices.
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EditorsEditors

Allow you to create and modify resources
– Where you do most of your work
– Any number of editors can be open at once, but only 

one can be active

Depending on the file resource type, the 
associated editor is displayed in the editor area

Editors are stacked in a tabbed notebook when 
several editors are open
– Optionally, can choose to tile them for simultaneous 

viewing

ActiveBPEL Designer's Editors are where most of your development work is done, 
and they allow the user to open, edit and save objects.  You can have as many 
Editors open as you want, and as many types of Editors as you want open at once 
(e.g., WSDL and process editors), but only one Editor can have focus at any given 
time.  Editors can be tiled inside the workbench, or they can be stacked on top of 
each other, using a tab-type of idiom.  If you grab a view’s Title bar and drag it, the 
mouse will change to an icon that will show you what happens when you drag it to 
certain areas, i.e., whether it will tile or stack on top of other Views when you drop it.   
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ViewsViews

Play a supporting role to the editors 
– Provide alterative presentations of data
– Ways to navigate through the information

Can appear by themselves or stacked with other 
views in a tabbed notebook
– Can also be resized, minimized, or maximized

ActiveBPEL Designer's Views support the editors and provide a presentation of 
specific data for whatever it is you are working on in the process editor.  For 
example, we can see it using an Outline view, which shows the process structure in 
a heirarchy…
Or, we can see a list of all of the Process Variables…
Or, we can see all the details on a specific activity, such as an Invoke or a While 
Loop.
Changes made in Views are generally saved immediately and will therefore be 
reflected immediately in other, related parts of the UI. 
Views, like Editors, can be stacked in tabs or they can be displayed on their own. 
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ResourcesResources

Collective term used to represent
– Files

Map to files in a file system

– Folders
Contain files and other folders
Map to directories in a file system

– Projects
Special type of folder
Contain files and other folders

ActiveBPEL Designer uses the term Resources for the files and folders available in 
the Workspace. 
Files map one-to-one to files in the File system.
Folders map one-to-one to directories in the file system, and can contain other 
folders and files. 
Projects are a special type of folder that contains other files and folders.  We'll talk 
more about Designer Projects later in this Unit…
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ActiveBPEL PerspectiveActiveBPEL Perspective

Default perspective to support the task of 
designing and implementing BPEL process 
definitions

Available Editors
– Process Editor

Available Views
– Navigator 
– Web References 
– Outline View 
– Properties View

Available Views 
(cont.)
– Process Variables 
– Error Log 
– Problems View
– Tasks View 
– Thumbnail View 
– Bookmarks View 

The ActiveBPEL Perspective is the default development environment for designing 
and implementing a process.  Here are the available Views, but note that not all of 
the available views have to be displayed at any given time.  You can open specific 
Views by using the  “Window->Show View->View Name menu “ selection.
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ActiveBPEL PerspectiveActiveBPEL Perspective

Here is the Default ActiveBPEL Perspective.  
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Navigator ViewNavigator View

Displays projects and their contents
– Folders and files associated with the Workspace

Navigator is a mirror image of the file system 
Workspace folder

The ActiveBPEL Designer's Navigator mirrors the file system’s “Workspace”
folder… A Workspace can contain one or more projects, and displays the folders 
and files that each of the projects contain.  Navigator shows all of the files and 
folders used by all of the projects in the current Workspace.
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Outline ViewOutline View

Hierarchical representation of a BPEL process

Supports full manipulation of the BPEL file
– Add, Delete, Reorder, etc.

Nodes in the outline synchronize with the 
Process Editor and the Properties view

The Designer's Outline view is one of the most useful views in the tool.  It shows the
contents of the entire project in a graphical, hierarchical representation and is a 
quick way to see the overall process flow.  The displayed resources are added to 
the Outline View in the same order in which they are created and items can be re-
arranged easily by dragging and moving them in the Outline View. Also, the nodes 
in the Outline view synchronize with the Process Editor and Properties View, so if 
you select an item in one, the same item is highlighted in the other two.  What this 
means is that when you move something in the process editor, for example, the 
Outline View is updated and vice-versa.  It also shows the internal operations of the 
various activities, such as the Copy operations inside each Assign activity, that can 
otherwise only be seen by drilling into the process diagram.
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Properties ViewProperties View

Show Categories

Show Advanced Properties

Restore Default Value

Property Category

Displays attribute (property) names and values 
for a selected item
– e.g., resource, process, or BPEL activity

Changes are automatically applied once the field 
loses focus

The Properties View will display different information depending on what is selected.  
For example, selecting a file in Navigator and then selecting Properties View will 
display the file size, path, etc.  Selecting an activity in the Process Editor will display 
relevant information about the activity under scrutiny, such as name, variables, etc.  
This supports the easy editing of activities, variables and other process data in one 
view.  The Properties View has different levels of visibility depending on what you 
need to see… such as Advanced Properties, Show Categories, etc., and like all 
views, it can be minimized or maximized as needed.  Just double-click on the tab or 
use the menu items. 
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Allows you to change the appearance and 
behavior of virtually everything in the 
ActiveBPEL Designer

View or modify your preferences by selecting 
Window>Preferences from the menu

PreferencesPreferences

You can find ActiveBPEL Designer's Preferences by going to the Windows-
>Preferences menu item.  These Preferences give you access to the Global 
settings that control the appearance and behaviour of the Designer.  For the most 
part, the Preference settings are not project-centric, but rather are associated with 
the Workspace, and therefore the settings here will apply to all projects in the 
workspace.  For example, the Auto-save default setting is every 5 minutes.  
Preferences categories include General, ActiveBPEL, Help, etc.
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ActiveBPEL Designer Help SystemActiveBPEL Designer Help System

The ActiveBPEL Designer Help system is integral to the tool, and is not accessed 
through a web connection.  When you are new to the tool, a good place to get 
started is with the Tutorial.   You can then follow up by taking this class, and 
exploring the rest of the Help.  The Help system also has Tips and Tricks, a set of 
Cheat Sheets for common tasks, and “hover help” that displays tooltips on for the 
item under scrutiny.  You can select any View or Editor and click F1 to open up 
context-sensitive Help for that item.  Finally, you can refer to the actual BPEL 2.0 
specification, as needed. 
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Unit ObjectivesUnit Objectives

At the conclusion of this unit, you will be familiar 
with:

ActiveBPEL Designer Environment
– Working with projects and resources
– Web References

Now that we've looked at the Designer's working environment, let's go on to projects 
and resources…
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WorkspaceWorkspace

A folder in your file system for storing your 
projects, their resources, and meta-data such as 
preferences
– The root of a workspace is the file system folder 

where its .metadata folder is located

All of the resources that you create with the 
Workbench are stored as normal folders and 
files
– Allows for the use of other external tools

It is an Eclipse requirement to designate a Workspace, inside which are your 
projects, resources and preferences.  When inside the file system, we can identify a 
Workspace by looking for the .metadata folder, which is the workspace root.  We 
can import a project and its preferences from our customers into a workspace, for 
example, so we can see it as they do.  All files are stored as normal files and folder, 
which allows you to use other, external tools in concert with the Designer.  
Note:  Designer's Project files use the ".project" extension and the Preferences files 
use the ".epf" extension
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ActiveBPEL ProjectsActiveBPEL Projects

Contains all of the required resources for the 
application you are building
– Includes BPEL, WSDL, XML Schema, and Sample 

Data resources

Files commonly used by BPEL Projects are .bpel, .wsdl, .xsd, .xml and .txt files.
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Creating Projects – Step 1Creating Projects – Step 1

1. Select File>New>Project
– New Project Wizard opens

2. Expand Simple and select Project, then select 
Next

To create a new project in ActiveBPEL Designer, go to the File menu and select 
New->Project to open the New Project wizard.  Then, Expand the General folder 
and select the project icon and click Next. 
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Creating Projects – Step 2Creating Projects – Step 2

Specify a name for the new project

By default, the project will be created in the 
Workspace folder
– Uncheck Use default checkbox to specify a location 

other than the default workspace

Note: The root of a project 
is the file system folder 
where its .project file is 
located

Name the project and the Designer will store the new project in a “.project” file that 
is added to the current Workspace.  The "Use Default" checkbox tells ActiveBPEL 
Designer to store the project in the default Designer folder, which was created at 
install time.  Uncheck this box to specify a location other than the default.  
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Use the Import Wizard to copy a project that 
either
– Exists in a different workspace
– Previously existed in a workspace

Steps
1. Select File>Import

• Import Wizard opens
2. Select Existing Project into 

Workspace and click Next
3. Browse to the root directory or

archive of project to import
4. Select project or projects
5. Select Finish to start the 

import

Import Existing ProjectImport Existing Project

You can also import an existing Designer project into a workspace.  This will import 
the original file(s), not a copy.  Browse to the project root and point to its root 
directory to import the project.  Note that deleting a project from a workspace does 
not delete the underlying project from the file system.  (And yes, it can be re-
imported.) 
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Use the Import File system wizard to import resources 
from the local file system into an existing project
– WSDL, Schema, Sample Data, etc.

Steps
1.Select File>Import

• Import Wizard opens
2.Select File System and 

click Next
3.Browse to the root directory 

to import resources from
4.Select the resources to import

from and which project to
import to

5.Select Finish to start the import

Import Resources From File SystemImport Resources From File System

You can also import “stand-alone” resources (.wsdl, .xsd, etc.) to add WSDL, 
Schema and other files into your project.  Note that when you import a file it imports 
a copy of the file.  The original file remains in the underlying file system. 
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Creating FoldersCreating Folders

1. In the Navigator view, right-click the project or folder 
where you want to create the new folder

2. From the pop-up menu, select New>Other
• New Resource Wizard opens

3. Expand General and select Folder, then select Next

4. Enter the name of the new folder and click Finish

To create a folder, go to the Navigator and Right-Mouse on the project to use the 
Resource Wizard, which allows you to create a new folder.  Note that the Right 
Mouse button is very powerful in ActiveBPEL Designer, and you should get in the 
habit of using it.  You can create separate folders for WSDL, sample data or for 
schema.  How you choose to arrange your files and data is your preference.
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Unit ObjectivesUnit Objectives

At the conclusion of this unit, you will be familiar 
with:

ActiveBPEL Designer Environment
Working with projects and resources

– Web References

Now that we’ve looked at Designer itself and at ActiveBPEL Designer projects, let's 
take a look at using Web References. 
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Web ReferencesWeb References

Provides the ability to catalog your SOA artifacts
– Shared across all projects within the Workspace

SOA Registry associated with your Workspace

– Currently WSDL and XML Schema files supported

Allows for quick assembly of a BPEL 
orchestration
– By either automatically creating or pre-filling the 

implementation details
– Enable bottom-up design approach

Web References is an SOA catalog of the artifacts that are in your .wsdl and .xsd 
files.  Once they are added to Web References, the individual artifacts are 
associated with the current Workspace, and may or may not be used by the 
current process or project.  This system allows forf the quick creation of BPEL 
processes by importing pre-defined functionality from your WSDLs and XSDs 
and supports a bottom-up approach to Process design.  So, if you have your 
PortTypes, Operations and Messages pre-defined, you just need to Drag & Drop 
them onto the canvas and then orchestrate them within the process. 
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Web References ViewWeb References View

View Web References

Add Web References

Remove Web References

Refresh Web References

Allows you to work with Web References 
associated with the current Workspace
– Add, View, Delete, Search, Filter Web References

Once files have been added to Web References, their artifacts are shared across all 
projects in the workspace.  The icons on the Web Reference View toolbar are: 
Add Web Reference, Remove Web References and Refresh Web References.  
Refreshing Web References updates the display against any changes in the 
underlying file.  The drop menu, that is located under the inverted triangle on the 
right, gives you multiple options to filter your views.  When you “filter” you are 
simply reading these files and showing the definitions that they contain.  So, 
when you filter for namespaces for example, you are seeing all the namespaces 
that are listed in all of the .wsdl files and .xsd files in the project, and underneath 
them you see the definitions they contain.
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Adding Web ReferencesAdding Web References

From the Web Reference View, Select Add Web 
Reference      from the toolbar or menu

Can add Web References from various locations

Can select multiple Web References from 
multiple locations at one time

To add Web References to your Workspace, browse either the file system or your 
projects, and then navigate where you need to go.  Currently, the Web References 
views support only .wsdl and .xsd files.  Note that if you browse Projects and select 
a file, when it is imported you will get a project-relative file location and if you 
browse the File System and select a file, when it is imported you will get a hard-
coded file location.  Be careful when doing this!  Files can have multiple versions 
located on your file system and network.  Make sure you are pointing to the right 
one.  It is usually the one that is in your project, so use the “Browse Projects” button 
and browse to your workspace and start looking from there.
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Adding Web References - LocationsAdding Web References - Locations

Via Project Location
– Resources located in a one of your projects

project:/MyProject/wsdl/loanapproval.wsdl

Via URL Location
– Resources located at a particular URL

http://hostname:port/wsdl/loanapproval.wsdl

Via File System Location
– Resources located on your local computer or network

file:////server/share/wsdl/loanapproval.wsdl
file:/C:/MyFolder/wsdl/loanapproval.wsdl

Note: Using Project or URL locations will make 
your projects more portable and easier to share

When you are adding Web References to your Workspace, Project relative is the 
best choic, URL is next best choice and file-relative is dead last.  Project relative, 
URL and File relative determine the path that is attached to the resource.  If you 
make everything project relative you can export the project and make it portable.  
Note that if you have absolute (file path) references they will probably not be any 
good once you start moving projects around.  These are normally only used for 
testing or teaching purposes.
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Adding Web References – ErrorsAdding Web References – Errors

When adding Web References errors might 
occur
– Examine the Error Log view for the list of errors and 

their details

When Web References are imported into your Workspace, the file is parsed to 
ensure that it is syntactically correct.  If it finds an error it will show the error and, if 
you click the details button, additional information in Error Log view.   
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Viewing Web ReferencesViewing Web References

To view the contents of a Web Reference
– Right-click on a Web Reference and select View Web 

Reference
Alternatively, double-click on a Web Reference or the Web 
Reference Menu

– Opens Web Reference in read-only mode

To examine the contents of a WSDL file you can select it and then use the Right 
Mouse menu to open it, or just double-click it.  When opened from Web References 
view the files are read-only because they are being used in the BPEL process.  If 
you want to edit these files you have to go into Navigator, make your changes, and 
then refresh the project folder in Navigator (which also refreshes the file reference.)  
Since the underlying file has now been changed, you must then refresh your Web 
References so that they reflect the changes.  
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Viewing WSDL Web ReferencesViewing WSDL Web References

Depicts a hierarchical outline of the complete 
WSDL structure
– Includes all BPEL specific extensions if present

Message

Message Parts

Port Type

Operation

Partner Link Type

Role

Bound Port Type Operations

Property

Property Alias 

As we know, a WSDL file has structure, and because of this it can be expanded out 
to see what is in there.  Each type of artifact in the structure has its own unique 
icon, such as those for a PortType, a Role or an Operation.  Note also that if you 
hover over these items, it will display relevant information for that kind of item.  The 
difference between this View and the Outline View is that this shows the .wsdl file 
under scrutiny only, while the Outline View shows the entire process and all .wsdl 
file contents, right? 



BPEL Fundamentals, Part 1

Copyright © 2004-2007 Active 
Endpoints, Inc. 35

35 Copyright © 2004-2007 Active Endpoints, Inc.35

Removing Web ReferencesRemoving Web References

From the Web Reference View, Select Remove 
Web Reference      from the toolbar or menu -

Only removes the entry from the registry
– Does not delete the underlying file

To remove Web References from the list simply select the file and use the Right 
Mouse menu to delete. Note that this only deletes the item from the Web 
References view itself, not from the Workspace or from the underlying file 
system.
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Refreshing Web ReferencesRefreshing Web References

From the Web Reference View, Select Refresh 
Web Reference      from the toolbar or menu -

Use Refresh when you have modified the 
underlying Web Reference File
– Causes the definition to be re-read from its location

If you edit a .wsdl or .xsd file (and remember that editing is available in Navigator 
only, not from the Web References View) you have to then refresh the project or 
project folder…and then refresh the Web References View, because otherwise you 
will be looking at the previous version of the file.  
File = Save saves current active Editor
File = Save As allows you to save the contents of the active Editor under another 
name or in another location
File = Save All saves the contents of all open editors 
In Navigator = Select the top level folder, open the Right Mouse menu and select 
Refresh.  This refreshes all files (synchs with file system)
In Navigator = Select the .project file, open the Right Mouse menu and select 
Refresh.  This refreshes all files referenced by the active project 
Web References View = Selecting Refresh Web References refreshes the Web 
Refrences tree, based on a read of the current files in the Navigator
Refresh Imports in the Outline View = Refreshes the imported files, based on the 
contents of the underlying files
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Web Reference View OptionsWeb Reference View Options

Provides ability to view Web References using 
various categorization options

No further information is 
provided

View Schemas

Expand to view message 
parts

View Messages

Expand to view 
associated Web 
References

View Namespaces

Expand to view 
associated roles and 
operations

View Partner Link 
Types

View all the WSDL Web 
References, expand to 
browse the complete 
WSDL structure

View WSDL

If you filter for .wsdl files you see everything that is inside the WSDLs, displayed in a 
hierarchical format.
If you filter for the partnerLinkTypes you see all of the Roles and Operations for 
each of the PartnerLinkTypes.
If you filter for the Namespaces, you can then drill into each namespace and see all 
of the resources defined within that namespace, such as its PLTs, Roles, 
Operations, Services, etc.
If you filter for Messages it lists all of the messages in all of the files, in alphabetical 
order, with no other references or connections.
If you filter for Schemas you see the schema file only.  (Note that this filter does not 
show you a listing of the various types defined in the schema.) 
Web Reference Sets allow you to only see the particular .wsdl and .xsd files you 
want to see, such as the ones you are currently working with.  Web Reference Sets 
allow you to select what files/schemas are displayed.  They are not removed from 
the project, just hidden from the current view.  So, for example, if you have a project 
with 50 .wsdl files and you are only working on 2 or 3 of them, you can created a 
reference set to narrow the focus and reduce clutter. 



BPEL Fundamentals, Part 1

Copyright © 2004-2007 Active 
Endpoints, Inc. 38

38 Copyright © 2004-2007 Active Endpoints, Inc.38

Lab 2 – Project SetupLab 2 – Project Setup

Overview of Lab Exercises
– Create new project
– Import resources from file system
– Add Web References
– Modify Workspace preferences

This is the second lab in the BPEL Fundamentals course.  Its purpose is to continue 
with the set up we began in Lab #1 and to get ready for the other labs that follow.  
During the course of this lab you will create a new ActiveBPEL Designer Project, 
import the provided files into the project (i.e., .wsdl and .xsd files), then add them to 
the Web References View.  When this is completed we'll modify some of the 
Designer's Workspace preferences. 
Lab #2:  has four tasks:
1.) Create a new Designer project
2.) Import the resource files provided for the course (WSDL and Schema) 
3.) Add these files to the Web References View
4.) Modify some of ActiveBPEL Designer's preferences. 
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Unit SummaryUnit Summary

Now you are familiar with
– ActiveBPEL Designer Environment
– Working with projects and resources
– Web References


